Upcoming Events

Jason Kelly Johnson will be running a one-day intensive Firefly/Arduino Workshop "RESPONSIVE BUILDING FACADES" on July 27, 2012 in San Francisco (as a part of the Architect's Newspaper "Art and Science of Building Facades" Symposium.) Register here.

*Read Jason's Hardware Recommendations blog post for 2012-13 Firefly Workshops.  

Are you teaching or participating in a workshop that is using Firefly?  Let us know about it and we'll feature it here on the Firefly website! (info@fireflyexperiments.com)

Discussions > Access to the port 'COM3'┬ádenied

I'm getting an error message from the Open Port component...

Solution exception: Access to the port 'COM3' denied.

Any idea what the problem may be?


February 25, 2011 | Unregistered CommenterKarl Williamson

Fixed it myself.

Just need to reboot and start the programs in the right order.

Now that it is working, Wow, this is awesome!

Thank you to everyone who worked on FireFly.


February 25, 2011 | Unregistered CommenterKarl Williamson

Thanks for your feedback!

February 26, 2011 | Registered CommenterEditor


Karl and Andy, can you let me know what the right order is?
Whenever I start GH+Firefly+Arduino Uno, that denial error always pops up and I should upload Friefly_Uno_frimata several times.
I am using rhino sr8 and GH 0.8. 0010
-Yong Ju

April 23, 2011 | Unregistered CommenterYong Ju

Hi Yong Ju,
Opening the serial port should be relatively straight forward... Essentially, all you need to do is to supply the proper COM port (either manually type it in if you know which port you're trying to connect to) or use the Ports Available component. You shouldn't need to change the Baud rate input (this is set by default to match the Firmata sketch). Then all you need to do is to hook up a boolean toggle to the Open input and set it to True.
The reason some people have had some problems is that there was a bug in the code (which has been resolved in the next release) where if you opened a sketch that already had a different port assigned... then it would throw you an error. For instance, let's say you're trying to connect to COM3, but when you opened an existing sketch and the COM port input had been set to COM4... then no matter if you changed the number back to 3... it still wouldn't open. The trick would be to save the file with the correct settings (so set the port to 3) and then close the file and re-open... this time it should work... All of this has been re-worked, so hopefully this issue wont happen in the next release... but hopefully that helps shed some light on the subject. My apologies for not catching the bug earlier. You said you had to unload the Firefly_Firmata sketch? You shouldn't need to do that at all... Just try the settings above, and let me know if you still can't connect to your board.

April 25, 2011 | Registered CommenterEditor


I am trying to do the firefly tutorial in the primer page 41. the grasshopper code works for one second and then gives an error that it cannot access com3. I am using Mega 2560 and connected it with the exact pins ins the tutorial.


April 22, 2012 | Unregistered Commenterarman

I figured that out. But the servo is not still working. shall I change servo's pin to servo or keep it digital?

April 22, 2012 | Unregistered Commenterarman

Hi arman,
yes, you need to set the state of the output pin to 'servo' if you're trying to control a servo with that pin. A digital signal will only send a HIGH/LOW signal out to that pin, which wont really do much if you've got the signal wire of your servo connected to that pin as well. Try switching it to servo.

April 23, 2012 | Registered CommenterEditor

i am using arduino uno but when i try to use the terminal software called tera term to get the print I get the error that access to COM3 is denied.I checked the port number in the sketch its already set to COM3 so no question of port number being changed later on.What could be the reason?Any suggestion will be valuable.


September 22, 2014 | Unregistered Commenterbikash

I'm having this problem with 3D printer. Arduino mega 2560.
I am not an expert at this stuff, so please be kinda detailed. I certainly appreciate it!


September 12, 2015 | Unregistered CommenterGpriv